Menu

Jumi

January 18th, 2013

JumiJumi is the set of custom code extensions for Joomla! 1.0.x, 1.5.x and 1.6.x in their native modes. Since 2006 more then 200.000 downloads.

With Jumi
* you can include php, html, javascript scripts into the modules position, articles, category or section descriptions, or into your own custom made component pages,
* you can even include static html or txt pages into your pages without using wrapper component,
* you have full access to Joomla! variables, functions, constants, etc. in your php scripts.

Jumi is ideal solution for
* including banners or text ads into your Joomla! site: no matter if your own or affiliates ones,
* easy and fast inclusion of smart javascript, php, html and dhtml scripts into your Joomla! content,
* fast development of not only small and simple customized modules and plugin solutions based on php, javascript and html or dhtml scripts like flash shows, ads and picture presentations, forms inclusion, etc. But for the development of more sophisticated solutions including database data processing.

For Jumi tips and tricks visit dedicated Tips & Tricks Jumi pages at http://2glux.com/projects/jumi/tutorial

Fix in 2.0.5: security vulnerability of the component.
Fix in 2.0.6: link changes

New in 2.0 (for J1.0 and J1.5): +component, + router (J1.5 only), +languages, +storage of custom code into a database table too, integration of all Jumi extensions.

Fix in 2.1.0 beta3: security vulnerability of the component.

New in 2.1 (still beta): direct code including into Joomla! content, pdf rendering, clearing the code from RSS feeds, security filtering option, debug mode in a plugin and a module, etc., etc.

New version for J!1.6 is ready. There is a problem with the module, so Jumi plugin is converted from Content to System, so you can place jumi syntax wherever you want in the site. There are also problems with the i18n, probably it is an issue in the core.

Jan 18, 2013: New version for J!3.0 is ready!

If you find issues, please report them: http://code.google.com/p/jumi/issues/list

NOTE: You can install 2.0.6 version on top of the previous version, without uninstalling it.

Keywords: custom code, custom php, custom script, include php, php code

Please do not use the reviews to post support requests or bug reports. Use the support forum instead.